HDU1312 Red and Black 搜索

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
题意:#为围墙,求包括@的格子数(不能越墙)

BFS:

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int a,b,c,d,ans,s;
char map[25][25];
int fx[4][2]={1,0,-1,0,0,1,0,-1};
struct node
{
	int x,y;
};
void bfs()
{
	node now,next;
    queue<node>q;
	now.x=c;
	now.y=d;
	map[now.x][now.y]='#';
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		
		for(int i=0;i<4;i++)     //以前没注意这里的int 卡住了很久 (递归)
		{ 
			next.x=now.x+fx[i][0];
			next.y=now.y+fx[i][1];			
			if(next.x>=0&&next.x<a&&next.y>=0&&next.y<b&&map[next.x][next.y]!='#')
			{			
				s++;	
				map[next.x][next.y]='#';			
				q.push(next);
			}
		}				
	}	
	return;
}
int main()
{
	while(~scanf("%d%d",&b,&a))
	{
		if(a==0&&b==0)
			break;
		getchar();
		s=1; 
		for(int i=0;i<a;i++)
			for(int j=0;j<b;j++)
			{cin>>map[i][j];
			if(map[i][j]=='@')
			{c=i;
			d=j;}
			}
			bfs();
			cout<<s<<endl;			
	}	
}

dfs:

#include<iostream>
#include<cstdio>
using namespace std;
int t,m,n,s,ss,a;
int fx[8][2]={-1,0,1,0,0,-1,0,1};    //上下左右四个方向
int vis[102][102];        //标记访问的数组
char map[102][102];
void dfs(int x,int y)
{     

	int xx,yy;
	for(int i=0;i<4;i++)        
	{
		if(x+fx[i][0]<1||x+fx[i][0]>m)  //越界则不考虑
			continue;
		if(y+fx[i][1]<1||y+fx[i][1]>n)  //同上
			continue;
		xx=x+fx[i][0];
		yy=y+fx[i][1];
		if(vis[xx][yy]==0&&map[xx][yy]=='.')      
		{
			vis[xx][yy]=1;  
			s++;
			dfs(xx,yy);
		}
	}
}
int main()
{
	int i,j;
    while(cin>>n>>m)
	{
		if(m==0&&n==0)
			break;
		s=1;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
				cin>>map[i][j];
			for(i=1;i<=m;i++)
				for(j=1;j<=n;j++)
					if(map[i][j]=='@')
					{
                                            vis[i][j]=1;
						dfs(i,j); //深搜起点
					}
					cout<<s<<endl;
	}
	return 0;
}

简单题 两种策略  bfs,dfs;bfs是以前敲的,,想起以前硬套模板的敲代码略有感触。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值