HDU 1042 N! 阶乘(大数)

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2

6

代码:

<pre name="code" class="java">import java.util.Scanner;
import java.math.BigInteger;  
public class Main {
	public static void main(String[] args) {
		Scanner cin= new Scanner(System.in);  //加快啥的
          int i;    
          int t;
          while(cin.hasNext()) //多重输入
          {
        	  t=cin.nextInt();    	
        	   BigInteger res=BigInteger.ONE;  
          for(i=2;i<=t;i++)
          {
        	  res=res.multiply(BigInteger.valueOf((long)i));     //将i的类型改为long 
          }
        	  System.out.println(res);
          }
	}
}

又一次证明JAVA的重要性 瞬间变水题啊 有木有。。


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值