HDU 1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 84569    Accepted Submission(s): 24938


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 
一个大数阶乘问题,用了java和c++两种语言来写,java就是普通的BigInteger,c++的话,思路就是用数组存每一位数字,相乘的时候就一位一位乘上去
C++:

#include<iostream>
using namespace std;
const int maxn=1e5;
int main(){
	int n;
	int num[maxn];
	while(cin>>n){
		num[0]=1;
		int cnt=1;
		for(int i=1;i<=n;i++){
			int k=0;
			for(int j=0;j<cnt;j++){
				int tmp=num[j]*i+k;
				num[j]=tmp%10;
				k=tmp/10;
			}
			while(k){
				num[cnt++]=k%10;
				k/=10;
			}
		}
		for(int i=maxn-1;i>=0;i--){
			if(num[i]) break;
			for(int j=cnt-1;j>=0;j--){
				cout<<num[j];
			}
		}
		cout<<endl;
	}
}
java:

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
    public static void main(String []args){
        Scanner cin=new Scanner(System.in);
        while(cin.hasNext()){
            int n;
            n=cin.nextInt();
            BigInteger ans=BigInteger.ONE;
            for(int i=1;i<=n;i++){
                ans=ans.multiply(BigInteger.valueOf(i));
            }
            System.out.println(ans);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值