Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4
题意:给一串数字 求最长递增序列的长度
代码:
#include<iostream>
using namespace std;
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int dp[1005],q[1005];
int m,n,i,j,s;
while(cin>>m)
{
s=1;
for(i=0;i<=m+1;i++)
{
dp[i]=1;
}
for(i=1;i<=m;i++)
cin>>q[i];
dp[1]=1;
for(i=2;i<=m;i++)
{
for(j=1;j<i;j++)
if(q[i]>q[j])
{
dp[i]=max(dp[j]+1,dp[i]);
}
if(dp[i]>s)
s=dp[i];
}
cout<<s<<endl;
}
return 0;
}