HDU 1242 rescue and 优先队列入门

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13 题意:一个牢房图,#是墙壁,a是angel,r是angel的朋友,x是敌人,每走一步消耗1个单位时间,消灭1个敌人也消耗一个单位时间,求r到a的最小时间。。 按照正常的思路:直接从R BFS 到 a 遇到 x就多加一个时间 就行了 不过这样是不对了(题目太水 还是A了) 伪AC代码:
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
#define w 205
char map[w][w];
int vis[w][w];
int sx,sy;
int m,n;
struct node {
	int x,y,time;
};
int fx[4][2]={1,0,0,1,-1,0,0,-1};
int bfs()
{
	int tx,ty;
	memset(vis,0,sizeof(vis));
	node now,next;
    queue<node>q;
	now.x=sx;now.y=sy;now.time=0;
	vis[sx][sy]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(map[now.x][now.y]=='r')
			return now.time;
		for(int i=0;i<4;i++)
		{
			tx=now.x+fx[i][0];
			ty=now.y+fx[i][1];
			if(tx<1||tx>m||ty<1||ty>n||vis[tx][ty]==1||map[tx][ty]=='#')
				continue;
			vis[tx][ty]=1;
			next.x=tx;
			next.y=ty;
			if(map[tx][ty]=='x')
				next.time=now.time+2;
			else
				next.time=now.time+1;
			q.push(next);
		}
	}
	return -1;
}
int main()
{
	int i,j;
	while(cin>>m>>n)
	{
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='a')
				{
					sx=i;sy=j;
				}
			}
			int ss= bfs();
			if(ss==-1)
				printf("Poor ANGEL has to stay in the prison all his life.\n");
			else
				printf("%d\n",ss);
	}
	return 0;
}

但面对这组数据:
3 4
a...
##x.
###r
结果 却是6(应该是5啊)
原因其实是(2,3) 和(1.4)是同步进入队列的 进入的顺序和方向数组有关= =

这个问题可以用优先队列解决, 详见代码

优先队列版:
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
#define w 205
char map[w][w];
int vis[w][w];
int sx,sy;
int m,n;
struct node {
	int x,y,time;
	bool operator <(const node & t) const         
    {
        return time>t.time;                  //改成<号 则较大的先出队
    } 
};
int fx[4][2]={1,0,0,1,-1,0,0,-1};
int bfs()
{
	int tx,ty;
	memset(vis,0,sizeof(vis));
	node now,next;
    priority_queue<node>q;                     //加上前缀  priority_
	now.x=sx;now.y=sy;now.time=0;
	vis[sx][sy]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.top();                       //优先队列不能用 q.front();
		q.pop();
		if(map[now.x][now.y]=='r')
			return now.time;
		for(int i=0;i<4;i++)
		{
			tx=now.x+fx[i][0];
			ty=now.y+fx[i][1];
			if(tx<1||tx>m||ty<1||ty>n||vis[tx][ty]==1||map[tx][ty]=='#')
				continue;
			vis[tx][ty]=1;
			next.x=tx;
			next.y=ty;
			if(map[tx][ty]=='x')
                    next.time=now.time+2;
			else
				next.time=now.time+1;
			q.push(next);
		}
	}
	return -1;
}
int main()
{
	int i,j;
	while(cin>>m>>n)
	{
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
			{
				cin>>map[i][j];
				if(map[i][j]=='a')
				{
					sx=i;sy=j;
				}
			}
			int ss= bfs();
			if(ss==-1)
				printf("Poor ANGEL has to stay in the prison all his life.\n");
			else
				printf("%d\n",ss);
	}
	return 0;
}

模板。。。

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值