Truck History(汽车的历史)——最小生成树

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19499 Accepted: 7519

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.



题意:汽车型号的历史性问题,给出一个最原始的汽车型号(都是7位字符串),然后是衍生出来的车的型号。为了弄明白卡车的编号是如何进行派生的,将不同型号的编码进行比对,算出其相对距离(即两字符串字符不相同的个数),然后由此计算派生的优劣值为所有距离和分之一,最后求最高优劣值。

解析:要求最高优劣值,即分母越小越好,也就是连接这些车的型号的距离和越少越好,这样就转换成了最小生成树问题。

首先,用二维数组来存储任意两车型号之间的距离,然后用prim算法计算最小生成树的权值。


#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#define maxint 0x3f3f3f3f


int mapp[2009][2009],n;
char car[2009][10];

void prim()
{
    int s[2009],dis[2009];
    int i,j,k,ans = 0;
    memset(s,0,sizeof(s));
    memset(dis,0,sizeof(dis));
    for(i = 1;i <= n;i++)
    {
        dis[i] = mapp[1][i];
    }
    s[1] = 1;
    for(i = 1;i < n;i++)
    {
        int mi = maxint,bj = 0;
        for(j = 1;j <= n;j++)
        {
            if(!s[j] && mi > dis[j])
            {
                bj = j;
                mi = dis[j];
            }
        }
        if(mi == maxint)
            break;
        ans += mi;
        s[bj] = 1;
        for(j = 1;j <= n;j++)
        {
            if(!s[j] && dis[j] > mapp[bj][j])
            {
                dis[j] = mapp[bj][j];
            }
        }
    }
    printf("The highest possible quality is 1/%d.\n",ans);
}

int main()
{
    int m,i,j,k;
    while(~scanf("%d",&n),n)
    {
        getchar();
        for(i = 1;i <= n;i++)
        {
            scanf("%s",car[i]);
            getchar();
        }
        for(i = 1;i < n;i++)
        {
            mapp[i][i] = maxint;
            for(j = i+1;j <= n;j++)
            {
                int num = 0;
                for(k = 0;k < 7;k++)
                {
                    if(car[i][k] != car[j][k])
                        num++;
                }
                mapp[i][j] = num;
                mapp[j][i] = num;
            }
        }
        prim();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值