Message Flood——发短信

Message Flood

Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

3

题意:

这个孩子有很多人要发短信,但是他已经发送了一些了,现在他想知道还有多少人没有发送。

解析:这道题目有很多种算法,字典树,MAP等,这里先讲字典树

其实是一道很简单的题目,不过MLE了很多遍,因为如果用字典树动态开辟内存,即使释放了也会MLE(因为卡的就是动态释放),在网上看了很多博客,都是用动态开内存的方法,这里就不写了,只贴出静态开内存的代码。

静态开辟内存,也就是数组的形式,先估算大约需要多少个节点,注意(每个节点都有26个子节点),然后将没有用的节点都初始化为-1,然后一个个的添加,查找的时候根据netx数组里记录的下标进行查找就可以了。


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>

using namespace std;

struct trie
{
    int next[26];
    bool sign;
} Trie[1000000];

int n,m,top = 0;

int newTrie()
{
    memset(Trie[top].next,-1,sizeof(Trie[top].next));
    Trie[top].sign = false;
    return top++;
}

void init(int k,char *sz)
{
    int j;
    for(int i = 0; i < strlen(sz); i++)
    {
        if(sz[i] >= 'A' && sz[i] <= 'Z')
            j = sz[i] - 'A';
        else
            j = sz[i] - 'a';
        if(Trie[k].next[j] == -1)
        {
            Trie[k].next[j] = newTrie();
        }
        k = Trie[k].next[j];
    }
    Trie[k].sign = true;
}

int lookup(int k,char *sz)
{
    int j;
    for(int i = 0; i < strlen(sz); i++)
    {
        if(sz[i] >= 'A' && sz[i] <= 'Z')
            j = sz[i] - 'A';
        else
            j = sz[i] - 'a';
        if(Trie[k].next[j] == -1)
            return 0;
        k = Trie[k].next[j];
    }
    if(Trie[k].sign == true)
    {
        Trie[k].sign = false;
        return 1;
    }
    else
        return 0;
}

int main()
{
    int k;
    char sz[30];
    while(~scanf("%d",&n),n)
    {
        scanf("%d",&m);
        top = 0;
        k = newTrie();
        newTrie();
        for(int i = 0; i < n; i++)
        {
            scanf("%s",sz);
            init(k,sz);
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%s",sz);
            n = n - lookup(k,sz);
        }
        printf("%d\n",n);
    }
    return 0;
}


MAP算法


将次数映射到人名上,然后根据已发送的查找,找到之后总人数减一。

需要注意的是,此题目不区分大小写,因此要是字母大小写统一。在写代码的时候,我将字母都转换成了小写,当然,也可以都转换成大写。

因为有多组输入,因此,每组输入结束后,要对容器进行清空

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <queue>
#include <map>
#include<algorithm>

using namespace std;

int main()
{
    int n,m;
    map<string,int>q;
    string sz;
    while(scanf("%d",&n),n)
    {
        q.clear();
        scanf("%d",&m);
        for(int i = 0;i < n;i++)
        {
            cin>>sz;
            transform(sz.begin(),sz.end(),sz.begin(),::tolower);
            q[sz]++;
        }
        for(int i = 0;i < m;i++)
        {
            cin>>sz;
            transform(sz.begin(),sz.end(),sz.begin(),::tolower);
            if(q[sz])
            {
                n--;
                q[sz] = 0;
            }
        }
        printf("%d\n",n);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值