杭电 A hard puzzle

                                        A hard puzzle

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0< a,b<=2^30)

Output

For each test case, you should output the a^b’s last digit number.

Sample Input

7 66
8 800

Sample Output

9
6

提示

求a^b的最后一位数字

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;

int pow(int a,int n,int b)//运用快速幂取模,a的n次方对b取余
{
    int result=1;
    a=a%b;
    while(n>0)
    {
        if(n%2==1)//如果n为奇数
        result=result*a%b;
        n=n/2;
        a=a*a%b;
    }
    return result;
}



int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        cout<<pow(a,b,10)<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值