HDOJ 1097 A hard puzzle(循环节||快速幂)


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9 6


法一:快速幂(指数的形式而且数值较大,直接快速幂)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL __int64
#define inf 0x3f3f3f3f
using namespace std;

LL n,m,e1,e2;
LL sf(LL a,LL b)
{
    LL ba=a,r=1;
    while(b!=0)//直到b除到0为止
    {
        if(b%2)//当b为奇数时才垒乘ba
        {
            r=(r*ba)%10;
        }
        ba=(ba*ba)%10;
        b>>=1;
    }
    return r;
}
int main()
{
    LL k,i,j,l;
    while(~scanf("%lld%lld",&n,&m))
    {
        l=sf(n,m);
        printf("%lld\n",l);
    }
    return 0;
}

法二:(找循环节)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL __int64
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    int n,m,j,k;
    while(~scanf("%d%d",&n,&m))
    {
        m%=4;
        n%=10;//就是底数没有取余。。而WA
        if(m==0)//当为0时再置为4
            m=4;
        k=1;
        while(m--)
        {
            k*=n;
        }
        printf("%d\n",k%10);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值