POJ 3641 Pseudoprime numbers

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8550 Accepted: 3590

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source



英语非常难读(好多从句OTZ)……读懂题就没问题了!

题意:费马定理:任意素数p和任意整数a(a>1)有如下性质:a的p次方除以p的余数等于a。

有一些同样具有这个性质的非素数p被称为基数a的伪素数。(所有符合条件的a都被称为卡迈克尔数)

现在给定两个数p和a,问p是否是a的伪素数。是的话输出“yes”,反之输出“no”


题解:先用快速幂判定任意的p是否符合费马定理,然后再判断p是不是素数~

大概后台给的数据比较少,我直接暴力判定素数也没TLE……最好还是打个表吧=。=(感觉我这个代码很容易被hack啊)


#include<stdio.h>
#include<string.h>
#include<math.h>
__int64 qp(__int64 a,__int64 p)
{
	__int64 ans=1;
	__int64 mod=p;
	while(p)
	{
		if(p&1)
			ans=ans*a%mod;
		a=a*a%mod;
		p>>=1;
	}
	return ans;
}
int main()
{
	__int64 p,a,i;
	while(scanf("%I64d%I64d",&p,&a),a||p)
	{
		int flag=0;
		__int64 temp=qp(a,p);
		if(temp==a)
		{
			for(i=2;i<sqrt(p);i++)
			{
				if(p%i==0)
				{
					flag=1;
					break;
				}
			}
			if(flag)
				printf("yes\n");
			else
				printf("no\n");
		}
		else
			printf("no\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值