POJ 3641:Pseudoprime numbers

17 篇文章 0 订阅
5 篇文章 0 订阅

Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output
no
no
yes
no
yes
yes


题意:不是素数的数p,且a^p对p取模等于a,输出yes,其他的输出no。
直接暴力,不要打表,打表数组开不到1e9,暴力不会超时


#include<stdio.h>
#include<math.h>
#define ll long long
ll Pow(ll a,ll b)
{
	ll res=1;
	ll c=b;
	while(b>0)
	{
		if(b&1) res=res*a%c;
		a=a*a%c;
		b>>=1;
	}
	return res;
}
ll su(ll n)
{
    for(ll i=2;i*i<=n;i++)  
    {
        if(n%i==0)
        return 0;
    }
    return 1;  
}
int main()
{
	ll p,a,flag=0;
	while(~scanf("%lld%lld",&p,&a))
	{
		if(a==0&&p==0) break;
		if(su(p)==0) flag+=1;
		if(flag!=0&&Pow(a,p)==a) printf("yes\n");
		else printf("no\n");
		flag=0;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值