Stones
Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 2046 Accepted Submission(s): 1347
Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Just output one line for one test case, as described in the Description.
Sample Input
2 2 1 5 2 4 2 1 5 6 6
Sample Output
11 12
Author
Sempr|CrazyBird|hust07p43
Source
Recommend
扔石头~
大意是有一个叫Sempr的人,他现在走在一条有石子的路上。当他碰到的石子是第i个(i为奇数时),他就会把石子扔出去~
现在给了每个石子的初始位置和一次扔多远,问Sempr能把石子扔的最远的距离。
题解:优先队列,要注意一下多个石子在一个位置的情况,这时候扔能扔最远的石子。
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
struct Stone
{
int p,d;
bool friend operator<(Stone a,Stone b)
{
if(a.p==b.p)
return a.d>b.d;
return a.p>b.p;
}
}a,temp;
int main()
{
int T;
int i,n;
scanf("%d",&T);
while(T--)
{
priority_queue<Stone> q;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a.p,&a.d);
q.push(a);
}
int ans=0;
int sum=0;
while(!q.empty())
{
ans++;
temp=q.top();
q.pop();
if(ans%2==0)
continue;
sum+=temp.d;
temp.p+=temp.d;
q.push(temp);
}
printf("%d\n",temp);
}
return 0;
}