HDOJ 1969 Pie

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9241    Accepted Submission(s): 3345


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
 

Source
 

Recommend
wangye
 


这个题啊,我原来刚接触二分的时候写过。当时只觉得难出天际连题解都看不懂照着别人代码抄都晕晕乎乎,最后因为觉得自己根本没理解所以没往博客上写,现在=。=我只觉得当时自己智商都掉完了。


题意:过生日给F+1个朋友分派。派可以切分,但是不能好几块拼一块分给别人,只能一块一块给。问一个人最多能吃到多大的派。


题解:其实跟前面我贴的分网线差不多。分派的大小,用朋友的数量判定。


#include<stdio.h>
#include<string.h>
#include<math.h>
#define PI acos(0)*2
double sum[10000+10];
int n,f;
int OK(double x)
{
	int ans=0;
	for(int i=0;i<n;i++)
	{
		ans+=(int)(sum[i]/x);
		if(ans>=f)	return 1;
	}
	return 0;
}
int main()
{
	int i,T;
	double tmp;
	scanf("%d",&T);
	while(T--)
	{
		memset(sum,0,sizeof(sum));
		scanf("%d%d",&n,&f);
		f++;
		double max=0.0;
		for(i=0;i<n;i++)
		{
			scanf("%lf",&tmp);
			sum[i]=tmp*tmp*PI;
			max+=sum[i];
		}
		double l=0.0,r=max/f;
		double mid;
		while(r-l>0.0000001)
		{
			mid=(l+r)/2;
			if(OK(mid))	l=mid;
			else	r=mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值