PieTime Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7318 Accepted Submission(s): 2740
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. ---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
Sample Output
|
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define eps 1e-5
#define PI acos(-1.0)
using namespace std;
const int maxn=10010;
double num[maxn];
bool judge(double mid,int n,int f){
int ans=0;
for(int i=0;i<n;++i){
ans+=(int)(num[i]/mid);
}
return ans>=f;
}
int main()
{
int t,i,j,k,n,f;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&f);
double maxnn=0;f++;
for(i=0;i<n;++i){
scanf("%lf",&num[i]);
num[i]=num[i]*num[i]*PI;
maxnn=max(maxnn,num[i]);
}
double l=0,r=maxnn,ans;
while(l-r<=eps){
double mid=(l+r)/2.0;
if(judge(mid,n,f)){
ans=mid;
l=mid+eps;
}
else {
r=mid-eps;
}
}
printf("%.4lf\n",ans);
}
return 0;
}