HDOJ 5777 domino

domino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 588    Accepted Submission(s): 301


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

Input
The first line of input is an integer T ( 1T10 )
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.( 2k,n100000 )
The second line has n - 1 integers, the distance of adjacent domino d, 1d100000
 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

Sample Input
  
  
1 4 2 2 3 4
 

Sample Output
  
  
9
 

Source
 


这题,我居然因为数型掉了!!!!!只是因为数型!!!!!!!!!sh*t!


题意:有n块多米诺,可以推k次,问多米诺的高度的和最小为多少时,所有多米诺能在k次内被推倒?


题解:不跨距离推距离远的,只推距离较近的。比如说样例,我们就把中间间隔为4的不推。推3然后让2连锁反应,所以样例中多米诺的高度是:

1 3 4 1

注意数型!!!!要用__int64!!!不然会爆……


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100000+10];
bool cmp(int x,int y)
{
	return x>y;
}
int main()
{
	int T;
	int i,n,k;
	scanf("%d",&T);
	while(T--)
	{
		memset(a,0,sizeof(a));
		scanf("%d%d",&n,&k);
		for(i=0;i<n-1;i++)
			scanf("%d",&a[i]);
		if(n==k)
			printf("%d\n",n);
		else
		{
			sort(a,a+n,cmp);
			__int64 sum=n;
			for(i=k-1;i<n-1;i++)
				sum+=a[i];
			printf("%I64d\n",sum);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值