HDOJ 5631 Rikka with Graph

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1037    Accepted Submission(s): 497


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

Source
 


这个题要注意一点,n个点要要能连接起来,最少需要n-1条边。所以这题可以暴力。但是时间很大(不过数据好像很弱所以没事)

一共给了n+1条边,我们只能去掉1条边或者2条边。2条以上的被去掉,肯定不能连通。


题意:一个人给了好多条边,问有多少种连法可以让这些点连通?


#include<stdio.h>
#include<string.h>
int per[111],u[111],v[111],use[111],n;

int Find(int x)
{
	while(x!=per[x])
		x=per[x];
	return x;
}
void Merge(int x,int y)
{
	int fx=Find(x);
	int fy=Find(y);
	if(fx!=fy)
		per[fx]=fy;
}
int Judge()
{
	int i;
	for(i=1;i<=n;i++)
		per[i]=i;
	for(i=0;i<=n;i++)
		if(use[i])
			Merge(u[i],v[i]);
	int cnt=0;
	for(i=1;i<=n;i++)
	{
		if(per[i]==i)
			cnt++;	
		if(cnt>1)
			return 0;
	}
	return 1;
}
int main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		memset(use,0,sizeof(use));
		scanf("%d",&n);
		for(i=0;i<=n;i++)
		{
			scanf("%d%d",&u[i],&v[i]);
			use[i]=1;
		}
		int ans=0;
		for(i=0;i<=n;i++)
		{
			use[i]=0;
			if(Judge())
				ans++;
			for(j=i+1;j<=n;j++)
			{
				use[j]=0;
				if(Judge())
					ans++;
				use[j]=1;
			}
			use[i]=1;
		}
		printf("%d\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值