HDOJ 5326 Work

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1707    Accepted Submission(s): 1025


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2
 

Author
ZSTU
 

Source
 


题意:我们都知道,所有的员工都有个头衔,每个头衔为BOSS的人就是领导。所以,如果A比B的的头衔大,我们就可以说A管理B。现在给你一个公司的关系图,问你有多少人管理着K个人。

第一行n表示人数,k不用说。后面n-1行表示关系,前面的是A后面的是B。


题解:这个题用的也是模拟压缩路径!每一次压缩新的节点的时候,不断往上查找,让它的父节点都+1表示增加了一个子节点。把每个节点连接的子节点个数存在数组里,最后直接取用。


#include<stdio.h>
#include<string.h>

int per[111],num[111];

int Find(int x)
{
	int r=x;
	while(r!=per[r])
		r=per[r];
	int i=x,j;
	while(i!=r)
	{
		j=per[i];
		num[j]++;
		i=j;
	}
	return r;
}
int main()
{
	int i,a,b,n,k;
	while(~scanf("%d%d",&n,&k))
	{
		memset(num,0,sizeof(num));
		for(i=1;i<=n;i++)
			per[i]=i;
		for(i=1;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			per[b]=a;
		}
		for(i=1;i<=n;i++)
			Find(i);
		int ans=0;
		for(i=1;i<=n;i++)
		{
			if(num[i]==k)
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值