hdoj5326Work(并查集)

117 篇文章 0 订阅
15 篇文章 0 订阅
Description



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Output
For each test case, output the answer as described above.
Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7
Sample Output

2

题意:父节点可以统领子节点,判断统领人数等于所给m的有多少个人。

思路:首先不得不吐槽一下这幅图不就是在说我们寝室老大么,回海南前和从海南回来的变化哈哈。

这道题首先保存一下等级制,就是谁是老大谁是兵。一级一级的保存,最后从级数最大(其实级数越大越往后官越小)开始搜索,每搜索一步对该数人数++(从最底层加起不会漏),级级递进最后就加到boss上了!这时所有的节点所统领多少人也出来了在搜索判断一下就搞定了!

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int pre[1010];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	r=pre[r];
	return r;
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	pre[y]=x;	
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		int a,b;
		int max=0;
		int p[110];
		int num[110];
		memset(num,0,sizeof(num));
		memset(p,0,sizeof(p));
		for(int i=1;i<=n;i++)
		pre[i]=i;
		for(int i=1;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			join(a,b);
			num[b]=num[a]+1;
			if(num[b]>max)
			max=num[b];
		}
		for(int i=1;i<=n;i++)
		{
			if(num[i]!=0)
			{
			int c=i;
			while(c!=find(i))
			{
				p[pre[c]]++;	
				c=pre[c];
			}
			}
		}
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			if(p[i]==m)
			sum++;
		}
		printf("%d\n",sum);
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值