A+B for Input-Output Practice (III)

A+B for Input-Output Practice (III)
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 38 Accepted Submission(s) : 23
Problem Description
Your task is to Calculate a + b.

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
0 0

Sample Output
6
30

#include<stdio.h>
int main()
{
	int a,b;
	scanf("%d %d",&a,&b);
	while(a!=0||b!=0){
		printf("%d\n",a+b);
	    scanf("%d %d",&a,&b);
	
	}
	return 0;
}

这里要特别注意题中说的“包含0 0的测试用例将终止输入,并且该测试用例将不被处理”这句话,写代码时循环条件容易误写成a!=0&&b!=0,其实当a为0但是b不为0或者当a不为0但是b为0时也需要处理,所以循环条件a!=0&&b!=0就出错了,应该把循环条件写成a!=0||b!=0

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值