Tian Ji -- The Horse Racing

Tian Ji – The Horse Racing
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 52 Accepted Submission(s) : 15
Problem Description
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”
在这里插入图片描述
Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

#include "stdio.h"
int main()
{
	int i,j,t,n,tian[1005],wang[1005],s=0,i1,j1;
	scanf("%d",&n);
	while(n!=0){
		for(i=0;i<n;i++){
			scanf("%d",&tian[i]);
		}
		for(i=0;i<n;i++){
			scanf("%d",&wang[i]);
		}
		for(i=1;i<n;i++){     //这里是给田忌的马和国王的马从小到大排序
			for(j=0;j<n-i;j++){
				if(tian[j]>tian[j+1]){
					t=tian[j];
					tian[j]=tian[j+1];
					tian[j+1]=t;
				}
				if(wang[j]>wang[j+1]){
					t=wang[j];
					wang[j]=wang[j+1];
					wang[j+1]=t;
				}
			}
		}
		i=0;     //表示田忌最慢的马	
		j=0;	 //表示国王最慢的马
		i1=n-1;  //表示田忌最快的马
		j1=n-1;	 //表示国王最快的马
		for(t=0;t<n;t++){
			if(tian[i1]>wang[j1]){	//先将两匹最快的马进行比较,如果田忌最快的马比国王的快,那么就用田忌最快的马和国王最快的马比赛
				s=s+200;
				i1--;
				j1--;
			}else if(tian[i1]<wang[j1]){  //如果田忌最快的马没有国王的快,那么就让田忌最慢的马和国王最快的马去比赛
				s=s-200;
				i++;
				j1--;
			}else{
				if(tian[i]>wang[j]){  //如果两匹最快的马速度一样的话,就让田忌最慢的马和国王最慢的马比,如果田忌最慢的马比国王的快,那么就让两匹最慢的去比赛
					s=s+200;
					i++;
					j++;
				}else if(tian[i]<wang[j]){  //如果田忌最慢的马比国王最慢的马慢,那么就让田忌最慢的马和国王最快的马去比赛
					s=s-200;
					i++;
					j1--;
				}else{   //如果两匹最快的马速度相等的条件下,两匹最慢的马速度也相等,那么就让田忌最慢的马和国王最快的马去比
					if(tian[i]<wang[j1]){  //如果田忌最慢的马比国王最快的马慢,那么就让田忌最慢的马去和国王最快的马去比赛,这个条件一定要写,不然如果田忌最慢的马和国王最快的马速度也相等但不写这个条件的话,结果就会是错的
						s=s-200;
		    			i++;
			    		j1--;
					}
				}
			}
		}
		printf("%d\n",s);
		scanf("%d",&n);
		s=0;
	}
	return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值