CSU——D: Daydreaming Stockbroker

Description

Gina Reed, the famous stockbroker, is having a slow day at work, and between rounds of solitaire she is daydreaming. Foretelling the future is hard, but imagine if you could just go back in time and use your knowledge of stock price history in order to maximize your profits!

Now Gina starts to wonder: if she were to go back in time a few days and bring a measly $100 with her, how much money could she make by just buying and selling stock in Rollercoaster Inc. (the most volatile stock in existence) at the right times? Would she earn enough to retire comfortably in a mansion on Tenerife?

Photo by liz west on flickr

Note that Gina can not buy fractional shares, she must buy whole shares in Rollercoaster Inc. The total number of shares in Rollercoaster Inc. is 100 000, so Gina can not own more than 100 000 shares at any time. In Gina’s daydream, the world is nice and simple: there are no fees for buying and selling stocks, stock prices change only once per day, and her trading does not influence the valuation of the stock.

Input

The first line of input contains an integer d (1 ≤ d ≤ 365), the number of days that Gina goes back in time in her daydream. Then follow d lines, the i’th of which contains an integer pi (1 ≤ pi ≤ 500) giving the price at which Gina can buy or sell stock in Rollercoaster Inc. on day i. Days are ordered from oldest to newest.

Output

Output the maximum possible amount of money Gina can have on the last day. Note that the answer may exceed 232.

Sample Input

6
100
200
100
150
125
300

Sample Output

650

思路:这题就是直接模拟就可以了,利用数组下标表示可能拥有的股票数,数据表示剩余的金钱.
每次只有两种操作,买入和卖出,但是要注意不能超过十万股,开始以为是限制条件,根本就没想着用,真是智障了。

#include<iostream>
#include<string.h> 
#include<set>
using namespace std;
typedef long long ll;
set<ll>s;ll m[100005]={};
int main()
{
        int n;
while(cin>>n)
{
s.insert(0);
m[0]=100;
while(n--)
{
ll temp;
cin>>temp;
for(set<ll>::iterator it=s.begin();it!=s.end();it++)
{
ll x=(*it)+m[(*it)]/temp;
                                ll y=m[(*it)]%temp;
if(x>100000)
{
y+=(x-100000)*temp;
x=100000;
}
s.insert(x);
m[x]=max(m[x],y);
m[0]=max(m[0],m[(*it)]+(*it)*temp);
}
}
cout<<map[0]<<endl;
}
return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值