Description
Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.
Input
Each line has two numbers n and b,1<=n<=1000000,2<=b<=500
Output
The answer,a number per line.
Sample Input
5 10 4 10
Sample Output
10 0
思路:由题意可以知道,给你两个数a,b,a可能是b的倍数,也可能不是,如果不是b的倍数,那么就要变成最近的那个b的倍数,如果离a最近的两个b的倍数距离相同则变为偏大的那个b的倍数。
那么思路就很明显了,先给个循环得到b*(i-1)<=a<=b*i;然后再判断距离,就可以了。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
int n,b;
while(cin>>n>>b)
{
int i=1;
while(1)
{
if(n>b*i)
i++;
else
break;
}
int temp1=b*i;
int temp2=b*(i-1);
if(temp1-n>n-temp2)
cout<<temp2<<endl;
else
cout<<temp1<<endl;
}
return 0;
}