CSU1040——Round-number

Description

    Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
    Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500

Output

The answer,a number per line.

Sample Input

5 10
4 10

Sample Output

10
0

思路:由题意可以知道,给你两个数a,b,a可能是b的倍数,也可能不是,如果不是b的倍数,那么就要变成最近的那个b的倍数,如果离a最近的两个b的倍数距离相同则变为偏大的那个b的倍数。

那么思路就很明显了,先给个循环得到b*(i-1)<=a<=b*i;然后再判断距离,就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n,b;
    while(cin>>n>>b)
    {
        int i=1;
        while(1)
        {
          if(n>b*i)
            i++;
          else
            break;
        }
        int temp1=b*i;
        int temp2=b*(i-1);
        if(temp1-n>n-temp2)
            cout<<temp2<<endl;
        else
            cout<<temp1<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值