动态规划之数塔问题

 

The Triangle

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50178 Accepted: 30325

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

IOI 1994

 

状态转移方程:if  i=n, maxSum[i][j]=D[i+1][j],  else  maxSum[i][j]=max(maxSum[i+1][j],maxSum[i+1][j+1])+D[i][j];

方法一:

 

  1. #include <iostream>    
    #include <algorithm>   
    using namespace std;  
       
    #define MAX 101  
        
    int D[MAX][MAX];      
    int n;    
    int maxSum[MAX][MAX];  
       
    int MaxSum(int i, int j){        
        if( maxSum[i][j] != -1 )           
            return maxSum[i][j];        
        if(i==n)     
            maxSum[i][j] = D[i][j];       
        else{      
            int x = MaxSum(i+1,j);         
            int y = MaxSum(i+1,j+1);         
            maxSum[i][j] = max(x,y)+ D[i][j];       
        }       
        return maxSum[i][j];   
    }   
    int main(){      
        int i,j;      
        cin >> n;      
        for(i=1;i<=n;i++)     
            for(j=1;j<=i;j++) {         
                cin >> D[i][j];         
                maxSum[i][j] = -1;     
            }      
        cout << MaxSum(1,1) << endl;   
    }   

     

 

方法二:降维此方法来源于http://blog.csdn.net/baidu_28312631/article/details/47418773

 

 我们首先需要计算的是最后一行,因此可以把最后一行直接写出,如下图:

   

 

    

    

    

    

    

    接下里的步骤就按上图的过程一步一步推导就可以了。进一步考虑,我们甚至可以连maxSum数组都可以不要,直接用D的第n行直接替代maxSum即可。但是这里需要强调的是:虽然节省空间,但是时间复杂度还是不变的。

 

Memory: 276K Time: 16MS

 

 

 

#include <iostream>
using namespace std;
#define MAX 101

int D[MAX][MAX];
int n;
int *maxSum;
int main()
{
    cin >> n;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=i; j++)
            cin >> D[i][j];
    }
    maxSum = D[n];
    for(int i=n-1; i>=1; i--)
    {
        for(int j=1; j<=i; j++)
            maxSum[j] = max(maxSum[j],maxSum[j+1])+D[i][j];
    }
    cout << maxSum[1] << endl;
    return 0;
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值