动态规划之划分数

Sumsets

Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 19389 Accepted: 7575

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver

题意:一个数可以被一些pow(2,k)的数相加得到,求有总共有多少种情况

方法一:

一、当n为奇数时,a[n]=a[n-1];

二、当n为偶数时有两种情况:

1、n=n-2+1+1;

2、n=n/2*2;

所以:a[n]=a[n-2]+a[n/2];

 

#include <iostream>
#include <cstdio>
using namespace std;
#define MAX 1000000

int N, i;
int dp[MAX+1];
void solve()
{
     dp[1] = 1;
     dp[2] = 2;
     for(i=3; i<=MAX+1; i++)
     {
     	if(i&1)
     		dp[i] = dp[i-1]%1000000000;
     	else
     		dp[i] = (dp[i-2]+dp[i/2])%1000000000;
	 }
}
int main()
{
    scanf("%d",&N);
    solve();
    printf("%d\n",dp[N]);
    return 0;
}

方法二(DP):

状态构造:
​d[i][j]表示前i个二的幂数凑成数j的方法数
​空间可以降维到d[j],表示凑成数j的方法数

终态:d[N],N是输入数字。

​状态转移方程:

​d[j]=d[j]+d[j-c[i]](其中d[j]表示不用c[i]就可以凑成j的方法数,d[j-c[i]]表示使用c[i]凑成j的方法数)

c[i]=2^i

​​初始化:​d[0]=1

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX = 1000001;
int dp[MAX];
int c;

int main()
{
    int N;
    while(cin >> N)
    {
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        c = 1;
        for(int i=1; i<=20 && c<=N; i++)
        {
            for(int j=c; j<=N; j++)
            {
                dp[j] = (dp[j]+dp[j-c])%1000000000;
            }
            c = c*2;
        }
        cout << dp[N] << endl;
    }
}

 

 

 

 

 

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值