关于PAT 1004 Counting leaves 的疑问

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input
2 1
01 1 02

Sample Output
0 1

注:leaf node

以下是我自己的代码,用dfs解决。答案都正确,但存在段错误,找了很久找不到原因。另外,代码还有其他不好的地方也可以指出来,希望有大神帮帮忙~

#include <iostream>
#include <vector>
using namespace std;

int ans[500] = { 0 };  // 每层中的叶结点数
int max_level = -1;

struct Node {
  int id;
  int child_num; // 子结点总数
  vector<int> vec;
  Node(int _id, int _child_num) {
    id = _id; child_num = _child_num;
  }
};

Node* all[500];  // 所有结点

void dfs(Node* node, int level) {
  if (level > max_level)
    max_level = level;
  if (node->child_num == 0)
    ans[level]++;
  for (int i = 0; i < node->child_num; i++) {
    if (all[node->vec[i]] != NULL) {
      dfs(all[node->vec[i]], level + 1);
    }
  }
}


int main(int argc, char const *argv[]) {
  int m, n, id, k, x;

  cin >> n >> m;

  for (int i = 0; i < 100; i++)
    all[i] = NULL;
  for (int i = 0; i < m; i++) {
    cin >> id >> k;
    Node* temp = new Node(id, k);
    for (int j = 0; j < k; j++) {
      cin >> x;
      (temp->vec).push_back(x);
      if (all[x] == NULL)
        all[x] = new Node(x, 0);
    }
    all[id] = temp;
  }
  dfs(all[1], 0);
  for (int i = 0; i < max_level; i++) {
    cout << ans[i] << " ";
  }
  cout << ans[max_level];
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值