HDU 1015

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 105994    Accepted Submission(s): 25777


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
ZJCPC2004

先说明自己的解法
首先最容易想到的就是递归了,但是由于n会比较大,所以栈会溢出。
这里使用找规律判断循环节的方法来做。由于是除7取余的,所以应该会有不大于取余之后只可能是0-6,
由于f[n]是由f[n-1]和f[n-2]决定,故最大7*7=49次一个循环,只要找到两个连续的1出现,
则可以确定为一次循环开始。但是这里说明的是可能不存在周期,因为当A,B都是7的倍数的时候,f[n]=0;

所以在代码中找周期的循环可能不一定能找到这个周期。所以我把数组大小从50改成55可能会发生错误。


#include<iostream>
#include<cmath>
#include<string>

using namespace std;
int main()
{
    int F[55];
    F[1]=1;
    F[2]=1;
    int a,b,n,m;
    while(cin>>a>>b>>n)
    {
        if(a==0 && b==0 && n==0)
            break;
        int i;
        for(i=3;i<55;++i)
        {
            F[i]=(a*F[i-1]+b*F[i-2])%7;
            if(F[i]==1 && F[i-1]==1)
            {
                m=i-2;
                break;
            }
        }
        if(n%(i-2)==0)
            cout<<F[i-2]<<endl;
        else
            cout<<F[n%(i-2)]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值