uva 227

 Puzzle 

A children's puzzle that was popular 30 years ago consisted of a 5x5 framewhich contained 24 small squares of equal size. A unique letter of thealphabet was printed on each small square. Since there were only 24 squareswithin the frame, the framealso contained an empty position which was the same size as a small square.A square could be moved into that empty position if it were immediately tothe right, to the left, above, or below the empty position. The object of thepuzzle was to slide squares into the empty position so that the framedisplayed the letters in alphabetical order.

The illustration below represents a puzzle in its original configuration andin its configuration after the following sequence of 6 moves:

 
		 1) 		 The square above the empty position moves.

2) The square to the right of the empty position moves.

3) The square to the right of the empty position moves.

4) The square below the empty position moves.

5) The square below the empty position moves.

6) The square to the left of the empty position moves.

Write a program to display resulting frames given their initial configurationsand sequences of moves.

Input

Input for your program consists of several puzzles. Each is described by itsinitial configuration and the sequence of moves on the puzzle. The first 5lines of each puzzle description are the starting configuration. Subsequentlines give the sequence of moves.

The first line of the frame display corresponds to the top line of squaresin the puzzle. The other lines follow in order. The empty position in a frameis indicated by a blank. Each display line contains exactly 5 characters,beginning with the character on the leftmost square (or a blank ifthe leftmost square is actually the empty frame position). The display lineswill correspond to a legitimate puzzle.

The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls todenote which square moves into the empty position. A denotes that the squareabove the empty position moves; B denotes that the square below the emptyposition moves; L denotes that the square to the left of the emptyposition moves; R denotes that the square to the right of the empty positionmoves. It is possible that there is an illegal move, even when it isrepresented by one of the 4 move characters. If an illegal move occurs, thepuzzle is considered to have no final configuration. This sequence of movesmay be spread over several lines, but it always ends in the digit 0. Theend of data is denoted by the character Z.

Output

Output for each puzzle begins with an appropriately labeled number(Puzzle #1, Puzzle #2, etc.). If the puzzle has no final configuration, thena message to that effect should follow. Otherwise that final configurationshould be displayed.

Format each line for a final configuration so that there is a single blankcharacter between two adjacent letters. Treat the empty square the sameas a letter. For example, if the blank is an interior position, then it willappear as a sequence of 3blanks - one to separate it from the square to the left, one for theempty position itself, and one to separate it from the square to the right.

Separate output from different puzzle records by one blank line.

Note:The first record of the sample input corresponds to the puzzle illustrated above.

Sample Input

TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAAAABBRRRLL0
Z

Sample Output

Puzzle #1:
T R G S J
X O K L I
M D V B N
W P   A E
U Q H C F

Puzzle #2:
  A B C D
F G H I E
K L M N J
P Q R S O
T U V W X

Puzzle #3:
This puzzle has no final configuration.

不用多说,简单模拟题,此题关键就在于输入的控制上。
代码:
#include <stdio.h>
#include <string.h>

using namespace std;
void exchange(char &a,char &b){
	char tmp;
	tmp=a;
	a=b;
	b=tmp;
}
int main(){
	char s[7][7];
	int num=1;
	while(gets(s[0])){
		if(strcmp(s[0],"Z")==0)
			break;
		for(int i=1;i<5;++i){
			gets(s[i]);
		}
		int x,y;
		for(int i=0;i<5;++i){
			for(int j=0;j<5;++j){
				if(s[i][j]==' '){
					x=i;
					y=j;
				}
			}		
		}
		
		char buf[1000];
		gets(buf);
		int len=strlen(buf);
		int flag=1;

		for(int i=0;i<len;++i)
		{
			if(buf[i]=='0' || buf[i]=='A' || buf[i]=='B' || buf[i]=='L' || buf[i]=='R')
			{
				if(buf[i]=='A'){
					if(x==0)
					{
						flag=0;
						break;
					}
					else
					{
						exchange(s[x][y],s[x-1][y]);
						x=x-1;
					}

				}
				if(buf[i]=='B'){
					if(x==4)
					{
						flag=0;
						break;
					}
					else
					{
						exchange(s[x][y],s[x+1][y]);
						x=x+1;
					}
				}
				if(buf[i]=='L'){
					if(y==0)
					{
						flag=0;
						break;
					}
					else
					{
						exchange(s[x][y],s[x][y-1]);
						y=y-1;
					}
				}
				if(buf[i]=='R'){
					if(y==4)
					{
						flag=0;
						break;
					}
					else
					{
						exchange(s[x][y],s[x][y+1]);
						y=y+1;
					}
				}

			}

		}
		printf("Puzzle #%d:\n",num++);
		if(flag==0)
			printf("This puzzle has no final configuration.\n");
		else{
			for(int i=0;i<=4;++i)
				 printf("%c %c %c %c %c\n", s[i][0], s[i][1], s[i][2], s[i][3], s[i][4]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值