哈理工团队赛 D pairs

D Pairs
Description Given N integers, count the number of pairs of integers whose sum is less than K. And we have M queries.
Input The first behavior is an integer T (1 < = T < = 10), on behalf of the number of sets of data. Each group of data is the first line N, M (1 < = n, m < = 100000), The next line will give N integers. a[i] (0<=a[i]<=100000). The next M lines, each line contains the query K (1 <= K<=200000).
Output For each query, output the number of pairs of integers whose sum is less than K.
Sample Input
1
5 2
1 5 3 4 2
5 7
Sample Output
2
6
题目是给你n个数,在给你m次询问,每次有一个k,问这n个数两两一对,有多少对的和等于k。

本来以为是什么高深的树啊,结果看了题解是fft(快速傅里叶变换),直接借鉴kuangbin巨巨的模板(虽然也不知道为啥,存个模板吧~)。
代码:

#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<cmath>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
//#define ll long long
#define inf 0x3f3f3f3f
const int spot=0;
const int edge=0;
const int maxn=400000+10;
const double pi=acos(-1.0);
struct comple
{
    double x,y;
    comple(double _x=0.0,double _y=0.0)
    {
        x=_x;
        y=_y;
    }
    comple operator -(const comple &b)const
    {
        return comple(x-b.x,y-b.y);
    }
    comple operator +(const comple &b)const
    {
        return comple(x+b.x,y+b.y);
    }
    comple operator *(const comple &b) const
    {
        return comple(x*b.x-y*b.y,x*b.y+y*b.x);
    }
};
void change(comple y[],int len)
{
    int i,j,k;
    for(i=1,j=len/2; i<len-1; i++)
    {
        if(i<j) swap(y[i],y[j]);
        k=len>>1;
        while(j>=k)
        {
            j-=k;
            k>>=1;
        }
        if(j<k)
            j+=k;
    }
}
void fft(comple y[],int len,int on)
{
    change(y,len);
    for(int h=2; h<=len; h<<=1)
    {
        comple wn(cos(-on*2*pi/h),sin(-on*2*pi/h));
        for(int j=0; j<len; j+=h)
        {
            comple w(1,0);
            for(int k=j; k<j+h/2; k++)
            {
                comple u=y[k];
                comple t=w*y[k+h/2];
                y[k]=u+t;
                y[k+h/2]=u-t;
                w=w*wn;
            }
        }
    }
    if(on==-1)
        for(int i=0; i<len; i++)
            y[i].x/=len;
}
comple x1[maxn];
int a[maxn>>2];
long long num[maxn],sum[maxn];
int main()
{
    int nn,i,j;
    scanf("%d",&nn);
    while(nn--)
    {
        memset(num,0,sizeof(num));
        int n,k;
        scanf("%d%d",&n,&k);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]),num[a[i]]++;
        sort(a,a+n);
        int len1=a[n-1]+1;
        int len=1;
        while(len<2*len1)
            len<<=1;
        for(i=0; i<len1; i++)
            x1[i]=comple(num[i],0);
        for(i=len1; i<len; i++)
        {
            x1[i]=comple(0,0);
        }
        fft(x1,len,1);
        for(i=0; i<len; i++)
            x1[i]=x1[i]*x1[i];
        fft(x1,len,-1);
        for(i=0; i<len; i++)
            num[i]=(long long)(x1[i].x+0.5);
        len=2*a[n-1];
        for(i=0; i<n; i++)
            num[a[i]+a[i]]--;
        for(i=1; i<=len; i++)
            num[i]>>=1;
        sum[0]=0;
        for(i=1; i<=len; i++)
            sum[i]=sum[i-1]+num[i];
        while(k--)
        {
            int x;
            scanf("%d",&x);
            printf("%lld\n",sum[x-1]);
        }
    }
    return 0;
}

/**************************************************************
    Problem: 1476
    User: acmlzq
    Language: C++
    Result: Accepted
    Time:4288 ms
    Memory:14456 kb
****************************************************************/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值