Count The Pairs


  With the 60th anniversary celebration of Nanjing University of Science and Technology coming soon, the university sets n tourist spots to welcome guests. Of course, Redwood forests in our university and its Orychophragmus violaceus must be recommended as top ten tourist spots, probably the best of all. Some undirected roads are made to connect pairs of tourist spots. For example, from Redwood forests (suppose it’s a) to fountain plaza (suppose it’s b), there may exist an undirected road with its length c. By the way, there is m roads totally here. Accidently, these roads’ length is an integer, and all of them are different. Some of these spots can reach directly or indirectly to some other spots. For guests, they are travelling from tourist spot s to tourist spot t, they can achieve some value f. According to the statistics calculated and recorded by us in last years, We found a strange way to calculate the value f: 
  From s to t, there may exist lots of different paths, guests will try every one of them. One particular path is consisted of some undirected roads. When they are travelling in this path, they will try to remember the value of longest road in this path. In the end, guests will remember too many longest roads’ value, so he cannot catch them all. But, one thing which guests will keep it in mind is that the minimal number of all these longest values. And value f is exactly the same with the minimal number. 
  Tom200 will recommend pairs (s, t) (start spot, end spot points pair) to guests. P guests will come to visit our university, and every one of them has a requirement for value f, satisfying f>=t. Tom200 needs your help. For each requirement, how many pairs (s, t) you can offer? 
Input
  Multiple cases, end with EOF. 
  First line:n m 
  n tourist spots ( 1<n<=10000), spots’ index starts from 0. 
  m undirected roads ( 1<m<=500000). 

  Next m lines, 3 integers, a b c 
  From tourist spot a to tourist spot b, its length is c. 0<a, b<n, c(0<c<1000000000), all c are different. 

  Next one line, 1 integer, p (0<p<=100000) 
  It means p guests coming. 

  Next p line, each line one integer, t(0<=t) 
  The value t you need to consider to satisfy f>=t. 
Output
  For each guest's requirement value t, output the number of pairs satisfying f>=t. 
  Notice, (1,2), (2,1) are different pairs. 
Sample Input
2 1
0 1 2
3
1
2
3
3 3
0 1 2
0 2 4
1 2 5
5
0 
2
3
4
5
Sample Output
2
2
0
6
6
4
4

0

思路 : 首先,对于n个点,易知,共有 n*(n-1) 条路径对,当限制1个t 的时候,我们可以把所有的 t 和线段都排序,对于某个t ,比它小的路径都连上,到边界去判断一下比t小的路径对有多少,然后用总的减去它就可以了,具体实现就可以用并查集了,因为只有连在一起的点才会有路径对,并且个数为当前为 n0*(n0-1);

这样大体思路有了,再加上点小优化,10秒稳过。

#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
#include<string>
#include<iostream>
#include<queue>
using namespace std;
typedef long long ll;

struct node{                    //存边
    ll x,y,dis;
    bool operator < (const node a)const  
    {
        return dis < a.dis;
    }
};

struct que{               //存询问
    ll t,i;
};

bool cmp(que a,que b)
{
    return a.t < b.t;
}

node side[500011];
que ques[500001];
ll pre[500001];
ll num[500001];
ll ans[500001];
ll tmp;
void init(int n)
{
    for(int i = 0; i <= n; i++)
    {
        pre[i] =i;
        num[i] = 1;
    }
}
ll Find(ll x)
{
    return pre[x] == x ? x : pre[x] = Find(pre[x]);
}
void join(ll x,ll y)
{
    ll fx = Find(x);
    ll fy = Find(y);
    if(fx!=fy)
    {
        pre[fy] = fx;
        tmp -= num[fy]*(num[fy]-1); // 及时更新防止超时
        tmp -= num[fx]*(num[fx]-1);
        num[fx] += num[fy];
        tmp += num[fx]*(num[fx]-1);
    }
}

int main()
{
     ll m,n;
     while(scanf("%lld%lld",&n,&m)!=EOF)
     {
         for(int i = 0; i < m; i++)
         {
             scanf("%lld%lld%lld",&side[i].x,&side[i].y,&side[i].dis);
         }
         ll q;
         scanf("%lld",&q);
         for(int i = 0; i < q; i++)
         {
             ques[i].i = i;
             scanf("%lld",&ques[i].t);
         }
         init(n);
         sort(ques,ques+q,cmp);
         sort(side,side+m);
         ll j = 0,sum = n*(n-1);
         tmp = 0;
         for(int i = 0; i < m; i++)
         {
             if(side[i].dis >= ques[j].t)
             {
                 ans[ques[j++].i] = sum - tmp;
                 if(j == q) break;
                 i--;
             }
             else
             {
                 join(side[i].x,side[i].y);

             }
         }
         for(; j < q; j++)
         {
             ans[ques[j].i] = 0;
         }
         for(int i = 0; i < q; i++)
         {
             printf("%lld\n",ans[i]);
         }
     }
     return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值