A+B for Matrices

<dl style="margin: 0px 0px 20px; padding: 0px; color: rgb(51, 51, 51); font-family: 'MicroSoft Yahei', Helvetica, Arial, Georgia, Simsun; font-size: 14px; line-height: 25px;"><dt style="margin: 0px 0px 10px; padding: 0px; font-size: 16px;"><strong>题目描述:</strong></dt><dd style="margin: 0px; padding: 0px;"><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px;"><span style="font-size:undefined;">    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.</span></p></dd></dl><dl style="margin: 0px 0px 20px; padding: 0px; color: rgb(51, 51, 51); font-family: 'MicroSoft Yahei', Helvetica, Arial, Georgia, Simsun; font-size: 14px; line-height: 25px;"><dt style="margin: 0px 0px 10px; padding: 0px; font-size: 16px;"><strong>输入:</strong></dt><dd style="margin: 0px; padding: 0px;"><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px;"><span style="font-size:undefined;">    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.</span></p><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px;"><span style="font-size:undefined;">    The input is terminated by a zero M and that case must NOT be processed.</span></p></dd></dl><dl style="margin: 0px 0px 20px; padding: 0px; color: rgb(51, 51, 51); font-family: 'MicroSoft Yahei', Helvetica, Arial, Georgia, Simsun; font-size: 14px; line-height: 25px;"><dt style="margin: 0px 0px 10px; padding: 0px; font-size: 16px;"><strong>输出:</strong></dt><dd style="margin: 0px; padding: 0px;"><p style="margin-top: 0px; margin-bottom: 0px; padding-top: 0px; padding-bottom: 0px;">    For each test case you should output in one line the total number of zero rows and columns of A+B.</p></dd></dl><dl style="margin: 0px 0px 20px; padding: 0px; color: rgb(51, 51, 51); font-family: 'MicroSoft Yahei', Helvetica, Arial, Georgia, Simsun; font-size: 14px; line-height: 25px;"><dt style="margin: 0px 0px 10px; padding: 0px; font-size: 16px;"><strong>样例输入:</strong></dt><dd style="margin: 0px; padding: 0px;"><pre style="white-space: pre-wrap;">2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
//A+B for Matrices

#include<iostream>
#include<string>
using namespace std;

bool iszero_row(int *A, int irow, int row, int col)
{
	int start = irow*col, end = irow*col + col;
	for(int i=start; i<end; i++){
		if(A[i]!=0)return false;
	}
	return true;	
}

bool iszero_col(int *A, int icol, int row, int col)
{
	int j;
	for(int j=0; j<row; j++)
	{
		if(A[icol+j*col]!=0)return false;
	}
	return true;
}

int main()
{
	int m,n,sum, *A, *B;
	while(cin>>m>>n)
	{
		if(m==0||n==0) break;
		sum = 0;
		A = new int[m*n];
		B = new int[m*n];
		for(int i=0; i<m*n; i++) cin>>A[i];
		for(int i=0; i<m*n; i++) cin>>B[i];
		for(int i=0; i<m*n; i++) A[i] = A[i] + B[i];
		
		/*for(int i=0; i<m*n; i++){
			cout<<A[i]<<" ";
			if((i+1)%n==0) cout<<endl;
		}*/
		for(int i=0; i<m; i++)
		{
			if(iszero_row(A, i, m, n))sum++;
		}
		for(int i=0; i<n; i++)
		{
			if(iszero_col(A, i, m, n))sum++;
		}
		cout<<sum<<endl;
	}
	delete[] B;delete[] A;
	return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值