九度OJ题目1041:Simple Sorting

该博客主要介绍了九度在线判题系统(OJ)中的一道编号为1041的题目,这道题目涉及到排序算法的应用。时间限制为1秒,内存限制为32兆,不采用特殊判题机制。目前已有4072次提交,成功解决的有1520次。
摘要由CSDN通过智能技术生成
题目1041:Simple Sorting

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4072

解决:1520

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8
来源:
2008年上海交通大学计算机研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7765-1-1.html

这个题也是排序而已,不同之处在于,要求我们剔除重复元素,我们未必真的剔除,只需在输出中体现就行,测试样例,输出为王!!!!!

#include <stdio.h>
#include <algorithm>

using namespace std;
int arr[1010];
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;++i)
            scanf("%d",&arr[i]);
        sort(arr,arr+n);
        int tmp=arr[0]+1;
        int numN=arr[n-1];
        for(i=0;i<n;++i)
        {
            if(arr[i]==numN)
            {
                printf("%d\n",numN );
                break;
            }
            if(arr[i]==tmp)
                continue;
            else
            {
                tmp=arr[i];
                printf("%d ",arr[i]);
            }
        }
    }
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值