PAT(Advanced Level) 1009 Product of Polynomials (25分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K
N
1
N_1
N1
a
N
1
a_{N_1}
aN1
N
2
N_2
N2
a
N
2
a_{N_2}
aN2 …
N
K
N_K
NK
a
N
K
a_{N_K}
aNKwhere K is the number of nonzero terms in the polynomial, Ni and aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤
N
K
N_K
NK <⋯<
N
2
N_2
N2 <
N
1
N_1
N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
#include <bits/stdc++.h>
using namespace std;
int k1, k2;
double A[1005], B[1005], C[1000005];
int main() {
scanf("%d",&k1);
for (int i = 0; i < k1; i++){
int x;double a;
scanf("%d%lf", &x, &a);
A[x] = a;
}scanf("%d", &k2);
for (int i = 0; i < k2; i++){
int x; double a;
scanf("%d%lf", &x, &a);
B[x] = a;
}
for (int i = 0; i <= 1000; i++)
for (int j = 0; j <= 1000; j++){
C[i + j] += A[i] * B[j];
}
int cnt = 0;
for (int i = 0; i <= 1000 * 1000; i++){
if (C[i] != 0) cnt++;
}
printf("%d", cnt);
for (int i = 1000*1000; i >= 0; i--){
if (C[i] !=0 ) printf(" %d %.1f", i, C[i]) ;
}
return 0;
}