【PAT甲级】 1009 Product of Polynomials

【PAT甲级】 1009 Product of Polynomials

原题

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 NK aNK

where K is the number of nonzero terms in the polynomial,Ni和aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK≤…≤N2≤N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input 1:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5

Sample Output 1:

    3 3 3.6 2 6.0 1 1.6

思路

题目要求

给定两个多项式,算多项式的乘法。

题目分析

  1. 格式:无多余空格,小数点后保留一位;
  2. 乘法和加减法不同,需要注意A多项式的每一项都要和B多项式的每一项相乘;
  3. 和前面多项式的题目很像,也是用空间换时间,但是B多项式输入时需要计算后再存储;

易错点

  1. 次数一样项数要记得相加;
  2. double再scanf中是%lf;

参考代码如下

#include <iostream>
using namespace std;
int main(){
	int n,m;
	//已经是第三种赋值方式了
	double arr1[1001]={0.0};//存储第一组数据
	double arr2[2001]={0.0};//存储结果
	scanf("%d",&n);
	int a;
	double b;
	for(int i=0;i<n;i++){
		scanf("%d %lf",&a,&b);
		arr1[a]=b;
	}
	scanf("%d",&m);
	for(int i=0;i<m;i++){
		scanf("%d %lf",&a,&b);
		for(int j=0;j<1001;j++){//不要错写成小于n之类的
			arr2[j+a]+=arr1[j]*b;
		}
	}
	int sum=0;
	for(int i=0;i<2001;i++){
		if(arr2[i]!=0.0) sum++;
	}
	printf("%d",sum);
	for(int i=2000;i>=0;i--){
		if(arr2[i]!=0.0) printf(" %d %.1f",i,arr2[i]);
	}
}

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值