(PAT Basic)1019.数字黑洞 C++

原题:https://pintia.cn/problem-sets/994805260223102976/problems/994805302786899968

给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:
输入给出一个 (0, 1 0 4 10^{4} 104)区间内的正整数 N。

输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

输入样例 1:

6767

输出样例 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例 2:

2222

输出样例 2:

2222 - 2222 = 0000

题目分析:
本体需要注意两个点:

  • 当输出的数字不足4位,前面要补0;
  • 当输入N=6174时,也要进行一次输出。

代码:
风格1: 看成整数处理

#include<iostream>
#include<algorithm>
using namespace std;

//非递增
int isDecreament(int a, int b) { return a >= b;}
int main() {
	int n;
	cin >> n;

	int up, down;
	 do{
		int nlist[4] = { n / 1000 ,(n % 1000) / 100 , (n % 100) / 10 ,n % 10 }; //取出n的各位用于排序
		sort(nlist, nlist + 4, isDecreament);
		down = nlist[0] * 1000 + nlist[1] * 100 + nlist[2] * 10 + nlist[3];
		up = nlist[3] * 1000 + nlist[2] * 100 + nlist[1] * 10 + nlist[0];
		n = down - up;
		
		printf("%04d - %04d = %04d\n", down, up, n);
	 } while (n != 6174 && n);

	system("pause");
	return 0;
}

风格2:看成字符串处理

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

//非递增
int isDecreament(char a, char b) { return a >= b;}
int main() {
	string n;
	cin >> n;
	n.insert(0, 4 - n.length(), '0'); //不足4位数的补全
	
	 do{
		 string a = n, b = n;
		 sort(a.begin(), a.end(), isDecreament); //非递增排序
		 sort(b.begin(), b.end()); //默认非递减排序
		 int result = stoi(a) - stoi(b);//字符串转整数
		 n = to_string(result);//整数转字符串
		 n.insert(0, 4 - n.length(), '0'); //不足四位,在前面补0
		 cout << a << " - " << b << " = " << n << endl;
	 } while (n != "6174" && n != "0000");

	system("pause");
	return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值