(PAT Advanced)1004.Counting Leaves(叶节点计数——树的遍历) C++

原题:https://pintia.cn/problem-sets/994805342720868352/problems/994805521431773184

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

题目分析:
给定一棵树,求每一层有多少个叶子结点。

广度优先遍历
使用邻接表存储家庭关系树,然后利用队列进行广度优先遍历
深度优先遍历
可设置全局辅助数组来保存各个层次的叶子结点数目,用递归或者栈实现深度优先遍历

#include<iostream>
#include<queue>
using namespace std;

typedef struct node_t {
	int info; // 信息
	int level;
	struct node_t* first = NULL; //第一个儿子
	struct node_t* next = NULL; // 兄弟结点
}node;
void BFS(node* tree);
void DFS(node* tree,int index,int depth);
int book[100] = {0}; // 用来记录深度优先遍历中每一层的叶子节点数
int maxdepth; // 最大深度
int main() {
	int N, M;
	node* tree = new node[100];
	while (cin >> N && N) {
		cin >> M;
		for (int i = 0; i < M; i++) {
			int info, n_children;
			cin >> info >> n_children;
			for (int j = 0; j < n_children; j++) {
				node* tmp = new node;
				cin >> tmp->info;
				// 头插法插入孩子结点
				tmp->next = tree[info].first;
				tree[info].first = tmp;
			}
		}
		//BFS(tree);
		DFS(tree, 1, 0);
		cout << book[0];
		for (int i = 1; i <= maxdepth; i++)
			cout << " " << book[i];
	}
	system("pause");
	return 0;
}
void DFS(node* tree,int index,int depth) {
	if (tree[index].first == NULL) {
		book[depth]++; // 表明是叶子结点
		maxdepth = max(maxdepth, depth);
		return;
	}
	// 访问孩子结点
	for (node* child = tree[index].first; child; child = child->next) {
		DFS(tree, child->info, depth + 1);
	}
}
void BFS(node* tree) {
	queue<int> Q;
	int count = 0;
	int first_level = 0;
	tree[1].level = first_level;
	Q.push(1);
	while (!Q.empty()) {
		int now = Q.front(); Q.pop();
		if (tree[now].level != first_level) {
			cout << count << " ";
			first_level++;
			count = 0;
		}
		if (tree[now].first == NULL) count++;
		for (node* child = tree[now].first; child; child = child->next) {
			//cout << "孩子" << child->info << " ";
			tree[child->info].level = tree[now].level + 1;
			Q.push(child->info);
		}
	}
	cout << count << endl;
}

注意,
此题由于结点的信息是数字,所以可以直接用int类型变量存储,这样可以直接用数组下标进行索引,比较方便。
同时,由于广度优先没有明显的层次关系,所以需要一个辅助变量level来记录当前层次。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值