HDOJ1060 Leftmost Digit(求n^n的最高位)

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15147    Accepted Submission(s): 5874


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
   
   
对任意一个数m可用科学记数法记为 m=10n * a(1<=a<10),使a的整数部分即为m的最高位数字
令m=numnum=10n * a
两边取对数: num*lg(num) = n + lg(a);
因为a<10,所以0<lg(a)<1
令x=n+lg(a); 则n为x的整数部分,lg(a)为x的小数部分
又x=num*lg(num);
a=10(x-n) = 10(x-int(x)))
再取a的整数部分即得num的最高位
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
typedef long long LL;
using namespace std;

int main(){
    int t,num;
    cin>>t;
    while(t--)
    {
        cin>>num;
        double temp= num*log10(num);
        double res= temp-floor(temp);
        int ans=(int)floor( pow( 10, res ) );
        cout<<ans<<endl;
    }
    return 0;
}
另有一题求n^n的最低位:HDOJ1061 Rightmost Digit

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值