题目描述 Description
在一个4*4的棋盘上摆放了14颗棋子,其中有7颗白色棋子,7颗黑色棋子,有两个空白地带,任何一颗黑白棋子都可以向上下左右四个方向移动到相邻的空格,这叫行棋一步,黑白双方交替走棋,任意一方可以先走,如果某个时刻使得任意一种颜色的棋子形成四个一线(包括斜线),这样的状态为目标棋局。
● | ○ | ● | |
○ | ● | ○ | ● |
● | ○ | ● | ○ |
○ | ● | ○ |
输入描述 Input Description
从文件中读入一个4*4的初始棋局,黑棋子用B表示,白棋子用W表示,空格地带用O表示。
输出描述 Output Description
用最少的步数移动到目标棋局的步数。
样例输入 Sample Input
BWBO
WBWB
BWBW
WBWO
样例输出 Sample Output
5
就像上面那道题,没有明确上限,所以可以自己定一个搜索上限,进行搜索,如果搜索不到结果就加深搜索深度。代码和深搜差不多,只需要加一个搜索上限就行了。
下面是代码:
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int inf = 0x3f3f3f3f;
char mp[4][5];
int ox1 = -1, oy1, ox2, oy2, ans;
int direction[4][2] = {{1,0}, {-1,0}, {0, 1}, {0,-1}};
bool check() // 判断是否达到目标情况
{
for(int i = 0; i < 4; i++)
{
if(mp[i][0]==mp[i][1] && mp[i][1]==mp[i][2] && mp[i][2]==mp[i][3]) return 1;
if(mp[0][i]==mp[1][i] && mp[1][i]==mp[2][i] && mp[2][i]==mp[3][i]) return 1;
}
if(mp[0][0]==mp[1][1] && mp[1][1]==mp[2][2] && mp[2][2]==mp[3][3]) return 1;
if(mp[0][3]==mp[1][2] && mp[1][2]==mp[2][1] && mp[2][1]==mp[3][0]) return 1;
return 0;
}
int dfs(int x1, int y1, int x2, int y2, char c, int step)
{
if(ans == step)
{
if(check()) return 1;
else return 0;
}
for(int i = 0; i < 4; i++)
{
int nx1 = x1+direction[i][0];
int ny1 = y1+direction[i][1];
int nx2 = x2+direction[i][0];
int ny2 = y2+direction[i][1];
if(nx1>=0 && nx1<4 && ny1>=0 && ny1<4 && c == mp[nx1][ny1])
{
swap(mp[nx1][ny1], mp[x1][y1]);
if(dfs(nx1, ny1, x2, y2, (c=='B'?'W':'B'), step+1)) return 1;
swap(mp[nx1][ny1], mp[x1][y1]);
}
if(nx2>=0 && nx2<4 && ny2>=0 && ny2<4 && c == mp[nx2][ny2])
{
swap(mp[nx2][ny2], mp[x2][y2]);
if(dfs(x1, y1, nx2, ny2, (c=='B'?'W':'B'), step+1)) return 1;
swap(mp[nx2][ny2], mp[x2][y2]);
}
}
return 0;
}
int main()
{
for(int i = 0; i < 4; i++)
{
scanf("%s", mp[i]);
}
for(int i = 0 ; i < 4; i++)
{
for(int j = 0; j < 4; j++)
{
if(mp[i][j] == 'O' && ox1 == -1)
ox1 = i, oy1 = j;
else if(mp[i][j] == 'O')
ox2 = i, oy2 = j;
}
}
for(ans = 0; ans < inf; ans++) // 每次设置一个搜索深度,如果搜索不到结果就加深
{
if(dfs(ox1, oy1, ox2, oy2, 'B', 0)) break;
if(dfs(ox1, oy1, ox2, oy2, 'W', 0)) break;
}
printf("%d\n", ans);
}
不懂迭代加深搜索的话可以去看看这个博客: 点击打开链接