题目描述 Description
已知有两个字串 A$, B$ 及一组字串变换的规则(至多6个规则):
A1$ -> B1$
A2$ -> B2$
规则的含义为:在 A$中的子串 A1$ 可以变换为 B1$、A2$ 可以变换为 B2$ …。
例如:A$='abcd' B$='xyz'
变换规则为:
‘abc’->‘xu’ ‘ud’->‘y’ ‘y’->‘yz’
则此时,A$ 可以经过一系列的变换变为 B$,其变换的过程为:
‘abcd’->‘xud’->‘xy’->‘xyz’
共进行了三次变换,使得 A$ 变换为B$。
输入描述 Input Description
输入格式如下:
A$ B$
A1$ B1$ \
A2$ B2$ |-> 变换规则
... ... /
所有字符串长度的上限为 20。
输出描述 Output Description
若在 10 步(包含 10步)以内能将 A$ 变换为 B$ ,则输出最少的变换步数;否则输出"NO ANSWER!"
样例输入 Sample Input
abcd xyz
abc xu
ud y
y yz
样例输出 Sample Output
3
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
string st, en, a[8], b[8];
int tot;
struct node{string x; int step;};
void bfs()
{
queue <node> q;
q.push((node){st, 0});
while(!q.empty() && q.front().step < 10)
{
node temp1 = q.front();
q.pop();
for(int i = 0; i < tot; i++)
for(int j = 0; j < temp1.x.length(); j++)
/*
string类型黑科技:
compare(从该位置开始,比较的长度,要比较的s)
replace(从该位置开始,替换中原串长度,替换串s)
*/
if(temp1.x.compare(j, a[i].size(), a[i]) == 0)
{
node temp2 = temp1;
temp2.x.replace(j, a[i].size(), b[i]);
if(temp2.x == en)
{
cout<<temp2.step+1<<endl;
return ;
}
q.push((node){temp2.x, temp2.step+1});
}
}
cout<<"NO ANSWER!"<<endl;
}
int main()
{
cin>>st>>en;
while(cin>>a[tot]>>b[tot]) tot++;
bfs();
return 0;
}