king's trouble II (单调栈)

Description

Long time ago, a king occupied a vast territory. Now there is a problem that he worried that he want to choose a largest square of his territory to build a palace. Can you help him? For simplicity, we use a matrix to represent the territory as follows: 0 0 0 0 0 0 1 0 1 0 1 1 1 1 0 0 1 1 0 0 0 0 1 0 0 Every single number in the matrix represents a piece of land, which is a 1*1 square 1 represents that this land has been occupied 0 represents not Obviously the side-length of the largest square is 2

Input

The first line of the input contains a single integer t (1≤t≤5) — the number of cases. For each case The first line has two integers N and M representing the length and width of the matrix Then M lines follows to describe the matrix 1≤N,M≤1000

Output

For each case output the the side-length of the largest square

Sample Input

2 5 5 0 0 0 0 0 0 1 0 1 0 1 1 0 1 0 0 1 1 0 0 0 0 1 0 0 5 5 0 0 0 0 0 0 1 0 1 0 1 1 1 1 0 0 1 1 0 0 0 0 1 0 0

Sample Output

1 2

题解:题目大意:劳烦您自己去读一下,只有尝试才会成长,我最开始也不愿意读英文题,but I have to do it.所以还是慢慢来吧。

          我的思路:和上一道单调栈的题一样,只不过这次要一行一行来处理,因为问题不同吗。不是很理解的话,去看看代码吧!

下面附上代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long
struct node
{
    int height;
    int startindex;
    node(int _height, int _index):height(_height), startindex(_index){};
};
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
      int mp[1010], currentposition, currentarea, maxarea = 0, N, M, x, height1;
      scanf("%d%d", &N, &M);
      for(int i = 1; i  <= N; i++)
      {
          for(int j = 1; j <= M; j++)
          {
             scanf("%d", &x);
             if(x)
                mp[j]++;
             else
                mp[j]=0;
          }
          stack<node> s;
          s.push(node(-1, 0));
          for(int j = 1; j < M+2; j++)
          {
             currentposition = j;
             if(j == M+1)
                 height1 = 0;
             else
                height1 = mp[j];
             node cur(height1, currentposition);
             while(height1<s.top().height)
             {
                 cur = s.top();
                 s.pop();
                 if((currentposition-cur.startindex)==cur.height)
                    currentarea = cur.height;
                 maxarea = max(maxarea, currentarea);
             }
             s.push(node(height1, cur.startindex));
          }
      }
      printf("%d\n", maxarea);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值