HDU5750(数论,素数筛法)

Dertouzos

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2125    Accepted Submission(s): 647


Problem Description
A positive proper divisor is a positive divisor of a number  n , excluding  n  itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not.

Peter has two positive integers  n  and  d . He would like to know the number of integers below  n  whose maximum positive proper divisor is  d .
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T106) , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  d   (2n,d109) .
 

Output
For each test case, output an integer denoting the answer.
 

Sample Input
  
  
9 10 2 10 3 10 4 10 5 10 6 10 7 10 8 10 9 100 13
 

Sample Output
  
  
1 2 1 0 0 0 0 0 4

题解:题目大意:老规矩,去读读吧!

          我的思路:先筛一遍素数,筛素数的时候只需要筛选到1e9开根号。至于为什么,因为他是要找小于n的切以d为最大因子的数。那么最多另外一个因子等于d,不可能大于d,因为大于d,d就不是最大因子了也就是d的平方小于n,所以素数筛出1e5就行了。然后从2到d的做小素因子跑一遍,素数的个数就最终的结果。这一点自己可以去思考一下。(为什么一定要是素数才满足题意? 还有就是为什么只需要遍历到d的最小素因子就行了?自己举个反例思考一下,对于搞算法的应该不难吧!)

下面附上代码:

#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<climits>
#include<map>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
int a[100005];
int main()
{
    for(int i = 2; i <= 1000; i++)
    {
        if(!a[i])
            for(int j = i*2; j <= 100000; j+=i)
            {
                a[j] = 1;
            }
    }
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, d, sum = 0;
        scanf("%d%d", &n, &d);
        for(int i = 2; i <= d; i++)
        {
            if(i*d >= n) break;
            if(!a[i]) sum++;
            if(!a[i] && d%i==0 && d!=i) break;
        }
        printf("%d\n", sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值