python中正确安装对应版本的包

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/AlanConstantineLau/article/details/69944743

python在写机器学习的代码过程中,需要引入如numpy、matpoltlib、pandas等等等。有时候直接pip install+对应的包名并不能正确安装,或者安装后依旧会出现安装不完全的情况。这里推荐一个基本包含了机器学习以及数据可视化功能的所有python包的下载网站Unofficial Windows Binaries for Python Extension Packages
里面的包大而全,比如一个numpy+mkl就需要一百多兆。同时,在下载的界面也会提示你安装这个包之前还需要添加什么依赖包。这里用matplotlib来举例子:
这里写图片描述
这意味着,你在安装matplotlib这个包之前,需要先把 numpy, dateutil, pytz, pyparsing, cycler, setuptools这几个包安装好,否则在matplotlib的使用过程中会导致部分功能无法使用。

其次,在上图中出现了很多版本的matplotlib,而哪一个又是适合自己电脑上的python呢?(这里肯定不是随便下载一个就可以了 ,否者会出现无法在该平台上安装的错误)
这里写图片描述
这里的1.5.3好理解,就是matplotlib这个包的版本号,而cpXX这是指适用的python版本号。比如cp27是指适用于python2.7版本,cp35适用python35。win32、win amd64则分别指32位和64位操作系统。

但是,为了能够更加准确的下载对应版本的包,在下载包之前,可以进行一下操作:

打开cmd输入python或者ipython
输入import pip;print(pip.pep425tags.get_supported())回车
*我这里使用的是python3.5
这里写图片描述
这里则返回了所有使用自己电脑上的python的包版本。
下载包的时候,只需要包的名称和上面的任一对应起来即可。

比如我这里查出了(‘cp35’, ‘cp35m’, ‘win_amd64’),所以我下载的matplotlib版本应为matplotlib‑1.5.3‑cp35‑cp35m‑win_amd64.whl
这里写图片描述

下载好这个包后,将这个包放到python安装路径下的Lib→site-packages(养成良好的包管理习惯)

再次打开CMD或者将打开刚刚查询版本号的cmd,摁下ctrl+D退出python或者ipython
然后在cmd中输入pushd python安装路径下的Lib→site-packages 比如我的就是pushd D:\Sofrware\Python35\Lib\site-packages
回车。
然后输入pip install 刚刚下载的包名,我这里是pip install matplotlib-2.0.0-cp35-cp35m-win_amd64.whl,等待pip将其安装完即可。或者进入python,输入import motplotlib进行检验是否安装成功。

除此之外,还可以上the Python Package Index来下载包,其安装方法与上述相同,这里就不再赘述。
这里写图片描述

展开阅读全文

没有更多推荐了,返回首页