杭电1381(hash或map分割子串个数)

2 篇文章 0 订阅

Time Limit: 10000/5000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”, “aab”, “aba”, “bab”, “bac”. Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1

3 4
daababac

Sample Output

5

思路:

题意:给定字符串分割为长度为n的子串,每个子串字符种类不超过nc个,求一共可以分割出多少个子串。

方法:可以使用Hash或者map,Hash不太会,就使用map解决。
(1)使用substr函数分割字符串。
(2)使用map,若子字符串出现过则值赋为1,未出现过则值赋为0,累加。
(3)注意每个样例输出之间要有空行。

AC代码:

#include <iostream>
#include <map>
#include <string.h>
using namespace std;

int main()
{
    int t;
    int n,nc;//子字符串长度,字符串中字母种类数
    cin>>t;
    for(int j=0;j<t;j++) 
    {
        if(t>1) cout<<endl;//因为样例之间要空一行
        string s;//输入的字符串 
        map<string,int>snum;
        cin>>n>>nc>>s;
        int k=0;
        int len=s.length();//字符串长度 
        for(int i=0;i<=len-n;i++)
        {
            string ss=s.substr(i,n);//从i开始长度为n的子字符串
            if(snum[ss]==0)//子字符串没出现过 
            {
                k++;//数量加1 
                snum[ss]=1;//标记为出现过 
            }
        }
        cout<<k<<endl;//输出子字符串数量 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值