HDU 1381 Crazy Search (hash)

Crazy Search

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1185    Accepted Submission(s): 463


Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5.
 

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
 

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Sample Input
1

3 4
daababac
 

Sample Output
5

/*
  NC进制的hash
  对于有x种字符的字符串,可以把每一个字符对应到x进制内的一个数,比如abcdee,有5个不
  同的字符,这样他可以用五进制来表示,其中可以用0表示a,1表示b,2表示c,3表示d,4表示
  d。这样就能把字符对应成整型来操作。那么对于刚才的abcdee,结果就是((((a*5+b)*5+c)*5+d)*5+e)*5+e;
  也就是((((0*5+1)*5+2)*5+3)*5+4)*5+4 = 12344,既用12344表示了abcdee这个字符串。
  
  15MS	16056K
  */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define SIZE 16000005
#define mod 16000005

using namespace std;

int n,nc;
char str[SIZE];
int hash[30];
bool vis[SIZE];

int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1; t<=T; t++)
    {
        scanf("%d%d",&n,&nc);
        scanf("%s",str+1);
        memset(hash,0,sizeof(hash));
        memset(vis,0,sizeof(vis));
        int len = (int)strlen(str+1);
        int val = 0;
        for(int i=1; i<=len; i++)  //对每个不同的字符对应到不同的整数
        {
            if(!hash[str[i]-'a'])
                hash[str[i]-'a'] = ++val;
            if(val == nc)
                break;
        }
        int ans = 0;
        for(int i=1; i<=len-n+1; i++) //枚举子串
        {
            int sum = 0;
            for(int j=i; j<=i+n-1; j++)
            {
                sum = sum*nc + hash[str[j]-'a'];
            }
            sum %= mod;
            if(!vis[sum])
            {
                vis[sum] = true;
                ans ++;
            }
        }
        printf("%d\n",ans);
        if(t != T)
            printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值