杭电1325(并查集+判断是否为树)

Is It A Tree?(难度:2)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
这里写图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

思路:

题意:判断是不是一棵树。每组输入以0 0 结束,输入以小于0的数结束。

解决:是否只有一个根节点,是否存在环形区域,是否除了根节点以外的其他结点入度为1。比1272题多一个判断入度的操作。本题代码是对于这个类型的输入的另一种解决方式。

方法:并查集+入度判断。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define maxn 1010
int tree[maxn];//并查集 
int in[maxn];//入度集 
int vis[maxn];

int findroot(int x)//查找函数 
{
    while(tree[x]!=x) x=tree[x];
    return x; 
}

void join(int x,int y)//合并函数 
{
    int fx=findroot(x);
    int fy=findroot(y);
    if(fx!=fy) tree[fx]=fy;
}

int main()
{
    int n,m,icase=0;
    int circle,ans,flag;//是否有环,几个根,标志位 
    //循环输入 
    while(1)
    {
        //init
        for(int i=1;i<maxn;i++)
        {
            tree[i]=i;
            vis[i]=0;
            in[i]=0;
        }
        circle=0;
        //输入nm,且nm不等于0 
        while(cin>>n>>m&&n!=0&&m!=0)
        {
            if(n<0&&m<0) return 0;//n,m<0,程序结束 
            vis[n]=vis[m]=1;
            in[m]++;//入度加1 
            if(findroot(n)==findroot(m)) circle=1;//同一个跟,则有环 
            join(n,m);
        }
        //有环,不是树 
        if(circle) cout<<"Case "<<++icase<<" is not a tree."<<endl;
        else
        {
            ans=0;
            flag=0;
            for(int i=1;i<maxn;i++)
            {
                if(vis[i]&&tree[i]==i)//判断是否连通
                {
                    ans++;
                    if(ans>1)//没有连通 
                    {
                        flag=1;
                        break;
                    }
                } 
                if(vis[i]&&in[i]>1)//入度大于1
                {
                    flag=1;
                    break;
                } 
            }
            if(flag!=0) cout<<"Case "<<++icase<<" is not a tree."<<endl;
            else cout<<"Case "<<++icase<<" is a tree."<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值