Max Sum(难度:1)
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
思路:
输出最大子串和,并输出子串的起始位置和结束位置。
递推公式:dp[i]=max(a[i],dp[i-1]+a[i])
AC代码:
#include <iostream>
#include <cstring>
using namespace std;
#define maxn 100010
int a[maxn];
int dp[maxn];
int main()
{
int t,n,sum,amax,icase=0,src,dest;
cin>>t;
while(t--)
{
cin>>n;
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
sum=0,amax=-1001;
for(int i=1;i<=n;i++)
{
cin>>a[i];
dp[i]=max(a[i],dp[i-1]+a[i]);//递推公式
if(amax<dp[i])//找到最大的dp[i]
{
amax=dp[i];
dest=i;
}
}
for(int i=dest;i>=1;i--)
{
sum+=a[i];
if(sum==amax) src=i;
}
cout<<"Case "<<++icase<<":"<<endl;
cout<<amax<<" "<<src<<" "<<dest<<endl;
if(t!=0) cout<<endl;
}
return 0;
}