杭电1078(仓鼠吃奶酪,DFS+动态规划)

22 篇文章 0 订阅
7 篇文章 0 订阅

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

思路:

题意:有一个n * n的网格,每个洞里藏有0~100块奶酪;仓鼠从(0,0)开始走,由于一只猫的存在,所以仓鼠每次只能走1~k步;由于吃了奶酪仓鼠会变胖,所以每一次走到的洞里的奶酪都要比上一次多;求仓鼠最多能吃多少块奶酪。

方法:动态规划 + 深度优先搜索

AC代码:

#include <iostream>
#include <cstring>
#include <stack>
using namespace std;

#define INF 0xfffffff
#define maxn 110
int dp[maxn][maxn];//dp[i][j]:从(i,j)开始能获得的最多奶酪 
int cheese[maxn][maxn];//记录每个位置有几块奶酪 
int n,k;//n个洞,每次最多走k步 

int dfs(int a,int b)
{
    if(dp[a][b]) return dp[a][b];
    dp[a][b]=cheese[a][b];
    for(int i=1;i<=k;i++)
    {
        //横坐标正向走i步,且下一个洞奶酪比当前的多 
        if(a+i<n&&cheese[a+i][b]>cheese[a][b])
        {
            dp[a][b]=max(dp[a][b],dfs(a+i,b)+cheese[a][b]);
        }
        //横坐标负向走i步,且下一个洞奶酪比当前的多
        if(a-i>=0&&cheese[a-i][b]>cheese[a][b])
        {
            dp[a][b]=max(dp[a][b],dfs(a-i,b)+cheese[a][b]);
        }
        //纵坐标负向走i步,且下一个洞奶酪比当前的多
        if(b-i>=0&&cheese[a][b-i]>cheese[a][b])
        {
            dp[a][b]=max(dp[a][b],dfs(a,b-i)+cheese[a][b]);
        }
        //纵坐标正向走i步,且下一个洞奶酪比当前的多
        if(b+i<n&&cheese[a][b+i]>cheese[a][b])
        {
            dp[a][b]=max(dp[a][b],dfs(a,b+i)+cheese[a][b]);
        }
    }
    return dp[a][b];
}

int main()
{
    while(cin>>n)
    {
        cin>>k;
        if(n==-1&&k==-1) break;
        memset(dp,0,sizeof(dp));//初始化
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>cheese[i][j];
            }
        }
        cout<<dfs(0,0)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值