POJ 3253(哈夫曼树)

Fence Repair

Time Limit: 2000MS
Memory Limit: 65536K

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

思路:

(1)题意:有一块长木头,要锯n-1次,锯成n块,锯多长就花多少钱,求花的最少的钱。

(2)例:锯2次,锯成3块,长度为8,5,8。即在长木头上先锯出21(8+5+8=21),再在21上锯出5,最后在21-5=16上锯出8,就得到8,5,8。花费为21+5+8=34。

(3)抽象:看做哈夫曼树的求解过程(求除了叶子节点之外的节点和)。

(4)方法:在集合中找出两块长度最短的木板,合并加入到集合中,重复过程,直到集合中只剩下一个元素。

(5)注意:求和时,使用long long sum

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
//构造小顶堆,即堆顶为最小的元素
priority_queue<int,vector<int>,greater<int> >q;
//大顶堆构造方法
//priority_queue<int>q;
int main()
{
    int n,t;
    while(cin>>n)
    {
        while(q.empty()==false) q.pop();
        for(int i=0;i<n;i++)
        {
            cin>>t;//输入叶子节点权值
            q.push(t);//放入堆中
        }
        long long ans=0;//保存结果
        while(q.size()>1)//堆中元素大于1个
        {
            int a=q.top();//取出堆顶元素作为左儿子
            q.pop();
            int b=q.top();//取出a后的堆顶元素作为右儿子
            q.pop();
            ans+=a+b;//父节点作为非叶子节点,权值为a+b
            q.push(a+b);//父节点权值放回堆中
        }
        cout<<ans<<endl;//输出答案
    }
    return 0;
}
  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值