POJ 1679(最小生成树+kruskal+记录边)

The Unique MST

Time Limit: 1000MS
Memory Limit: 10000K

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
1. V’ = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

思路:

题意:给出一个图,判断它的最小生成树是否唯一。

方法:

  • kruskal求最小生成树的值+记录边
  • 对每条边,判断去掉这条边后是否能够构成值相同的最小生成树

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

#define maxn 10010
#define INF 0x3f3f3f3f 

struct node{
    int x;
    int y;
    int d;
}tree[maxn];

int t,n,m;//t样例n个点m条边 
int x,y,d;//点x与点y构成的边权值为d 
int ans,cnt,mst;//结果,记录建边变量,
int flag;
int f[maxn];//父亲节点 
int path[maxn];//记录路径 

int cmp(node a,node b)
{
    return a.d<b.d;
}

void init()
{
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
    }
}

int find(int x)
{
    if(x!=f[x]) f[x]=find(f[x]);
    return f[x];
}

void kruskal()
{
    init();
    sort(tree,tree+cnt,cmp);
    for(int i=0;i<m;i++)
    {
        int fx=find(tree[i].x);
        int fy=find(tree[i].y);
        if(fx!=fy)
        {
            f[fy]=fx;
            path[cnt++]=i;//记录路径 
            ans+=tree[i].d;
        }
    }
    //去掉每一条边 
    for(int k=0;k<cnt;k++)
    {
        init();
        int sum=0;
        int j=0;
        for(int i=0;i<m;i++)
        {
            if(i==path[k]) continue;
            int fx=find(tree[i].x);
            int fy=find(tree[i].y);
            if(fx!=fy)
            {
                f[fy]=fx;
                sum+=tree[i].d;
                j++;
            }
        }
        //判断是否构成树并且是否与最小生成树值相等 
        if(j==n-1&&sum==ans)
        {
            flag=0;
            return ;
        }
    }
}

int main()
{
    cin>>t;
    while(t--)
    {
        cnt=0;
        init();
        cin>>n>>m;//n点m边 
        for(int i=0;i<m;i++)//依次输入m条边 
        {
            cin>>tree[i].x>>tree[i].y>>tree[i].d;//点x与点y构成的边权值为d
        }
        flag=1;
        cnt=0;
        ans=0; 
        kruskal();
        if(flag) cout<<ans<<endl;
        else cout<<"Not Unique!"<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值