杭电1002(两个大数加法)

3 篇文章 0 订阅

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

思路:

大数加法

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define maxn 1010
#define INF 0x3f3f3f3f

int main()
{
    string a,b;
    int num,sum[1000];
    cin>>num;
    for(int i=0;i<num;i++)
    {
        cin>>a>>b;
        int m=0,n=0,temp=0;//m+n,temp为进位 
        int j,k;
        int len=0;
        j=a.length();
        k=b.length();
        j=j-1;
        k=k-1;
        while(j>=0&&k>=0)
        {
            m=a[j]-'0';
            n=b[k]-'0';
            sum[len++]=(temp+m+n)%10;
            temp=(temp+m+n)/10;
            j--;
            k--; 
        }
        if(j>k)
        {
            while(j>=0)
            {
                m=a[j]-'0';
                sum[len++]=(temp+m)%10;
                temp=(temp+m)/10;
                j--;
            }
        }
        if(k>j)
        {
            while(k>=0)
            {
                m=b[k]-'0';
                sum[len++]=(temp+m)%10;
                temp=(temp+m)/10;
                k--;
            }
        }
        sum[len]=temp;
        cout<<"Case "<<i+1<<":"<<endl;
        cout<<a<<" + "<<b<<" = ";
        if(sum[len]!=0) cout<<sum[len];
        for(--len;len>=0;len--)
        {
            cout<<sum[len];
        }
        cout<<endl;
        if(i<num-1) cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值