CodeForces 596 B Wilbur and Array

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">描述:给定n个整数都为0,要把这n个整数变成输入的序列。有两种操作:从第i个数开始往后都+1或者-1;</span>
<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">直接暴力从前往后走一遍就行,前面的符合序列后就不用管了,相当于只操作两个数,求解hi-h(i-1)的差。记得用数学函数哦:<math.h>求绝对值</span>
<span style="font-family:Arial, Helvetica, sans-serif;">解题收获:分析问题的方式不要局限,灵活思维,还有<math.h>包含了数学中强大的很多函数。</span>

题目:Description

Wilbur the pig is tinkering with arrays again. He has the array a1, a2, ..., an initially consisting of n zeros. At one step, he can choose any index i and either add 1 to all elements ai, ai + 1, ... , an or subtract 1 from all elements ai, ai + 1, ..., an. His goal is to end up with the array b1, b2, ..., bn.

Of course, Wilbur wants to achieve this goal in the minimum number of steps and asks you to compute this value.

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 200 000) — the length of the array ai. Initially ai = 0 for every position i, so this array is not given in the input.

The second line of the input contains n integers b1, b2, ..., bn ( - 109 ≤ bi ≤ 109).

Output

Print the minimum number of steps that Wilbur needs to make in order to achieve ai = bi for all i.

Sample Input

Input
5
1 2 3 4 5
Output
5
Input
4
1 2 2 1
Output
3

Sample Output

Hint

In the first sample, Wilbur may successively choose indices 1, 2, 3, 4, and 5, and add 1 to corresponding suffixes.

In the second sample, Wilbur first chooses indices 1 and 2 and adds 1 to corresponding suffixes, then he chooses index 4 and subtract 1.


题解:

/****************************************
 * Author: alei
 * Created Time: 2015
 * project name:
*****************************************/

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>

using namespace std;

#define MAX_SIZE 200005

long long b[MAX_SIZE];
long long n, ans;//数据量

int main()
{
    while( cin >> n)
    {
        ans = 0;
        for( int i=0; i<n; i++)
        {
           cin>> b[i];
        }
        long long fir = 0;
        for(int i=0; i<n; i++)
        {
            if(fir != b[i])
            {
                ans += abs(b[i]-fir);//后一个和前一个的差的绝对值
                fir = b[i];//记录前一个
            }
        }
        cout<< ans <<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值